Deprecated: iconv(): Passing null to parameter #3 ($string) of type string is deprecated in /home/h202023492/elcut.ru/docs/elc_menu.php on line 125
Приемы управления окнами - справка ELCUT
Новый подход
к моделированию полей

Главная >> Поддержка >>

Приемы управления окнами

справка ELCUT

Содержание справки

ELCUT позволяет одновременно работать с несколькими документами (описания задач, геометрические модели, физические свойства и др.). Работа с отдельными типами документов будет обсуждаться в специальных главах, а здесь мы опишем общие приемы создания новых или открытия существующих документов, переключения между ними и другие подобные моменты.

В ELCUT в основном встречаются три типа окон:

Окна разных типов по-разному размещены на экране.
Приемы управления окнами

Окна задач

Окно задачи обычно приклеено к левой границе главного окна ELCUT. Если одновременно открыто несколько задач, их окна складываются в столбик вдоль левого края главного окна, либо накладываются друг на друга в виде вкладок. Вы можете приклеить любое окно задачи к любой границе окна, расположить его в виде вкладки к другому окну задачи или свойств, расположить окна в столбик, в строку, организовать несколько столбцов или строк. Можно также оставить окно плавающим над другими окнами.

Чтобы изменить расположение окна задачи, просто отбуксируете его мышью в нужное место, взяв за полоску заголовка окна. В процессе перетаскивания на экране появятся стрелочки с кнопками. Не отпуская левую кнопку мыши, наведите курсор на любую стрелочку, и ELCUT подсветит предполагаемое расположение окна, которое оно займет, когда вы отпустите кнопку мыши.

Окна документов

Окна документов (например, окно геометрического редактора, картины поля или схемы электрической цепи) не приклеиваются к границам. Эти окна целиком или частично заполняют остаток свободного места в главном окне ELCUT. Для удобства переключения между ними вдоль нижней границы главного окна расположены вкладки, подобно панели задач Windows.

Окно документа может быть свернуто в значок, развернуто до максимального размера или принимать свой обычный размер, который вы можете менять, потянув мышью за любой из углов окна. Это может быть полезно, когда вы хотите видеть несколько документов одновременно. Кроме того, вы можете автоматически разложить на экране все несвернутые окна без перекрытия, выбрав позицию Сверху вниз или Слева направо в меню Окна.

Некоторые окна могут быть расщеплены на две или четыре части. Чтобы разделить окно, укажите мышью разделитель - маленький серый прямоугольничек, расположенный в верхней части вертикальной полосы прокрутки и в левой части горизонтальной полосы. Когда указатель мыши изменит свою форму, отбуксируйте разделитель в нужное место.

Можно также использовать команду Разделить в меню Окна. Переключаться из одной части окна в другую можно, указав мышью нужную зону или используя клавишу F6.

Чтобы отменить расщепление окна, дважды щелкните на разделителе или отбуксируйте его к границе окна, пока он не исчезнет.

Окна инструментов

Окна инструментов – полевой калькулятор, цветная шкала, перечень элементов электрической цепи и пр., расположены внутри соответствующего окна документа и приклеены к его границе. Подобно окнам задачи, вы можете буксировать и приклеивать инструменты в пределах своего окна документа. Окно инструмента может быть оставлено плавающим. Тогда его можно отбуксировать и за пределы родительского окна.

Окно свойств

Окно свойств можно открыть или закрыть командой Свойства в меню Вид. Это окно обычно приклеено к окнам задач (как на рисунке), либо может быть оставлено плавающим. В окне отображаются свойства текущего объекта (задачи, геометрической модели и т.п.). Часть свойств приводится для информации (они помечены серым цветом), другие можно изменять прямо в этом окне. Для изменения свойства просто впишите нужное значение, либо выберите его из списка. Измененное значение свойства вступает в силу немедленно.

Создание новых и открытие существующих документов

Создание новой задачи и нового документа

Чтобы создать новую задачу, запустите ELCUT и выберите команду Создать задачу в меню Файл, либо соответствующую кнопку на панели инструментов. Далее следуйте указаниям Мастера создания задачи.

В редких случаях бывает полезным создавать новые документы ELCUT других типов: геометрическую модель, электрическую цепь или файл описания физических свойств того или иного типа. В такой ситуации воспользуйтесь командой Создать файл в меню Файл и выберите из меню нужный тип документа.

Замечание. Правильно установленный ELCUT регистрирует несколько типов файлов, которые можно создавать, не запуская ELCUT. Для этого используйте команду Файл > Создать из проводника Windows.

Открытие существующей задачи и других документов

Чтобы открыть существующую задачу ELCUT, используйте команду Открыть задачу в меню Файл, либо кнопку на панели инструментов.

Документы ELCUT других типов удобно открывать через меню Задача или двойным щелчком над нужным файлом в окне задачи. Если нужно открыть документ ELCUT, не ассоциированный с текущей задачей, воспользуйтесь командой Открыть файл в меню Файл и выберите из меню нужный тип документа.

Замечание. Зарегистрированные за ELCUT типы файлов можно открывать прямо из проводника Windows двойным щелчком мыши. Можно также перетаскивать файлы из проводника Windows в окно ELCUT.

Чтобы закрыть документ выберите пункт Закрыть в меню Файл или щелкните кнопку закрытия в верхнем правом углу рамки окна документа. Если документ был изменен со времени последнего сохранения, ELCUT спросит вас о необходимости сохранить внесенные изменения.

Чтобы переключиться с одного окна на другое в переделах ELCUT, используйте закладки в нижней части окна ELCUT, либо меню Окна, либо просто щелкните мышью в окне, в которое вы хотите перейти.

Сертификаты ELCUT по ГОСТ, СП, ИСО, СанПиН